squashfs file system · Maintained
Maintainers
- M Phillip Lougher <phillip@squashfs.org.uk>
Paths
- F
Documentation/filesystems/squashfs.rst - F
fs/squashfs/
Last 30 days
Recent patches
Most-recent 28 patches in this subsystem on linux-block, ordered by date desc.
-
STALE85d
[PATCH 13/61] squashfs: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden> -
STALE216d
[PATCH v3 6/9] block: Replace the repetitive bio chaining code patterns
2025-11-29 · zhangshida <hidden> -
STALE215d
[PATCH v2 08/12] block: Replace the repetitive bio chaining code patterns
2025-11-28 · zhangshida <hidden> -
STALE224d
[PATCH 5/9] block: use bio_chain_and_submit for simplification
2025-11-21 · zhangshida <hidden> -
STALE302d
[PATCH 1/2] block: add a bio_init_inline helper
2025-09-08 · Christoph Hellwig <hch@lst.de> -
STALE945d
[PATCH 1/3] block: Rework bio_for_each_segment_all()
2023-11-22 · Kent Overstreet <kent.overstreet@linux.dev> -
STALE1126d
[PATCH v2 1/5] block: Rework bio_for_each_segment_all()
2023-06-05 · Kent Overstreet <kent.overstreet@linux.dev> -
STALE1130d
[PATCH 4/7] block: Rework bio_for_each_segment_all()
2023-05-25 · Kent Overstreet <kent.overstreet@linux.dev> -
STALE978d
[PATCH 12/32] block: Rework bio_for_each_segment_all()
2023-05-09 · Kent Overstreet <kent.overstreet@linux.dev> -
DORMANTno replies
[PATCH v2 1/2] block: Rework bio_for_each_segment_all()
2023-04-04 · Kent Overstreet <kent.overstreet@linux.dev> -
STALE1193d
[PATCH 1/2] block: Rework bio_for_each_segment_all()
2023-03-27 · Kent Overstreet <kent.overstreet@linux.dev> -
STALE1544d
LANDED: 1 (1M) [PATCH 2/5] squashfs: always use bio_kmalloc in squashfs_bio_read
2022-04-06 · Christoph Hellwig <hch@lst.de> -
STALE1544d
LANDED [PATCH 4/5] block: turn bio_kmalloc into a simple kmalloc wrapper
2022-04-06 · Christoph Hellwig <hch@lst.de> -
DORMANTno replies
Re: [PATCH 4/5] block: turn bio_kmalloc into a simple kmalloc wrapper
2022-04-01 · Christoph Hellwig <hch@lst.de> -
STALE1561d
Re: cleanup bio_kmalloc v2
2022-03-31 · Christoph Hellwig <hch@lst.de> -
STALE1561d
[PATCH 4/5] block: turn bio_kmalloc into a simple kmalloc wrapper
2022-03-08 · Christoph Hellwig <hch@lst.de> -
STALE1561d
REVIEWED: 1 (1M) [PATCH 2/5] squashfs: always use bio_kmalloc in squashfs_bio_read
2022-03-08 · Christoph Hellwig <hch@lst.de> -
STALE1591d
[PATCH 4/5] block: turn bio_kmalloc into a simple kmalloc wrapper
2022-03-01 · Christoph Hellwig <hch@lst.de> -
STALE1591d
[PATCH 2/5] squashfs: always use bio_kmalloc in squashfs_bio_read
2022-03-01 · Christoph Hellwig <hch@lst.de> -
STALE1570d
LANDED: 1 (1M) [PATCH 17/19] block: pass a block_device and opf to bio_alloc
2022-01-24 · Christoph Hellwig <hch@lst.de> -
STALE1632d
[PATCH 17/19] block: pass a block_device and opf to bio_alloc
2022-01-18 · Christoph Hellwig <hch@lst.de> -
STALE1725d
LANDED: 2 (1M) [PATCH 23/30] squashfs: use bdev_nr_bytes instead of open coding it
2021-10-18 · Christoph Hellwig <hch@lst.de> -
STALE1726d
REVIEWED: 1 (1M) [PATCH 23/30] squashfs: use bdev_nr_bytes instead of open coding it
2021-10-15 · Christoph Hellwig <hch@lst.de> -
STALE1730d
[PATCH 22/29] squashfs: use bdev_nr_sectors instead of open coding it
2021-10-13 · Christoph Hellwig <hch@lst.de> -
STALE1789d
LANDED [PATCH 06/15] squashfs: use bvec_virt
2021-08-04 · Christoph Hellwig <hch@lst.de> -
STALE1947d
LANDED [PATCH] block: rename BIO_MAX_PAGES to BIO_MAX_VECS
2021-03-11 · Christoph Hellwig <hch@lst.de> -
STALE3537d
[PATCH 12/16] block,fs: untangle fs.h and blk_types.h
2016-11-01 · Christoph Hellwig <hch@lst.de> -
STALE3627d
REVIEWED: 7 (7M) [PATCH 04/45] fs: have ll_rw_block users pass in op and flags separately
2016-06-05 · <hidden>